Protect Ctrlx Down

Incident Report for ThreatX

Resolved

This issue has been identified and resolved.
Posted Jul 31, 2025 - 19:19 MDT

Investigating

Ctrlx for protect.threatx.io is currently down and being investigated.

Please note that this only impacts protect.threatx.io and not x.threatx.io.

We will update as soon as we have additional information.
Posted Jul 31, 2025 - 18:42 MDT
This incident affected: ThreatX Dashboard.