Degraded performance on ThreatX Dashboard

Incident Report for ThreatX

Resolved

ThreatX Engineering believes the problem has been addressed. All customers should now be able to login without delays through all SSO providers.
Posted Feb 25, 2025 - 12:17 MST

Update

ThreatX Engineering has observed the connection issues appear to be subsiding. At this time we are no longer observing client timeouts for any customer attempting to log in to the ThreatX Dashboard. We will continue to monitor and troubleshoot for slow login symptoms.
Posted Feb 25, 2025 - 10:29 MST

Update

ThreatX Engineering is continuing to investigate this issue. We believe we have narrowed down the problem to customers using Microsoft Azure SSO to log in to the ThreatX Dashboard. All other functionality including application protection appears to be unaffected at this time.

ThreatX Engineering is actively investigating this issue and will provide updates as more information becomes available.
Posted Feb 25, 2025 - 09:57 MST

Investigating

ThreatX Engineering has identified degraded performance and intermittent timeouts affecting the ThreatX Dashboard page. The problem appears to be an intermittent issue at this time. ThreatX Engineering is actively investigating this issue and will provide updates as more information becomes available.
Posted Feb 25, 2025 - 09:46 MST
This incident affected: ThreatX Dashboard.